If you're using IdT with the solution pack, here's something you'll want to consider.

The "Recent Activity" report covers a 2 week period which uses a RDD for getting it's information.

The problem is that, by default, the evt_rpt_xxx table is not partitioned. As a result, this table size can grow quite significantly. We had 200GB+ sizes just for this table even though I was manually vacuuming it every few weeks. The table doesn't appear to be captured in the automatic vacuum process that occurs within Sentinel.

This is caused by the way PostgreSQL uses the file system....it writes data which takes disk space, when it deletes data it doesn't release the space unless vacuum is run.

By Edit'ing the "RDD: [sentinel.identity.rdd] Identity Recent Activity" Data Synchronisation policy and enabling "Partition table:", when the data is no longer used it is actually deleted from disk. We now have 16 tables (1 table per day / 2 weeks + template table + 1 extra day) with a total size of 157GB with no vacuuming required.

NOTE: To enable Partitioning, the table has to be truncated, so you will loose the last 2 weeks until the table(s) is repopulated.