Hi,

I planed to upgrade to Sentinel 7.4.3 from 7.3.1, but the upgrade
failed, because it has much configuration data and event data, so
sentinel can`t be deleted, but when i try to exec to
"./install-sentinel" script, it prompt it has been up to date
version(7.4.3), how to do it? error information is following:


Thu 10 Nov 2016 04:00:30 PM CST 2016-11-10 08:00:30 GMT|0|LOG:
redirecting log output to logging collector process
Thu 10 Nov 2016 04:00:30 PM CST 2016-11-10 08:00:30 GMT|0|HINT: Future
log output will appear in directory "/var/opt/novell/sentinel/log".
Thu 10 Nov 2016 04:00:31 PM CST alter role postgres login
Thu 10 Nov 2016 04:00:31 PM CST select usename from pg_user
Thu 10 Nov 2016 04:18:44 PM CST LOG: skipping missing configuration
file
"/var/opt/novell/sentinel/3rdparty/postgresql/data/postgresql.auto.conf"
Thu 10 Nov 2016 04:18:44 PM CST 2016-11-10 08:18:39 GMT|0|FATAL:
database files are incompatible with server
Thu 10 Nov 2016 04:18:44 PM CST 2016-11-10 08:18:39 GMT|0|DETAIL: The
data directory was initialized by PostgreSQL version 9.2, which is not
compatible with this version 9.4.1.
Thu Nov 10 16:25:56 2016 LOG: skipping missing configuration file
"/var/opt/novell/sentinel/3rdparty/postgresql/data/postgresql.auto.conf"
Thu Nov 10 16:25:56 2016 2016-11-10 08:25:51 GMT|0|FATAL: database
files are incompatible with server
Thu Nov 10 16:25:56 2016 2016-11-10 08:25:51 GMT|0|DETAIL: The data
directory was initialized by PostgreSQL version 9.2, which is not
compatible with this version 9.4.1.
Thu Nov 10 16:27:33 2016 LOG: skipping missing configuration file
"/var/opt/novell/sentinel/3rdparty/postgresql/data/postgresql.auto.conf"
Thu Nov 10 16:27:33 2016 2016-11-10 08:27:28 GMT|0|FATAL: database
files are incompatible with server
Thu Nov 10 16:27:33 2016 2016-11-10 08:27:28 GMT|0|DETAIL: The data
directory was initialized by PostgreSQL version 9.2, which is not
compatible with this version 9.4.1.
Thu 10 Nov 2016 04:11:00 PM CST LOG: skipping missing configuration
file
"/var/opt/novell/sentinel/3rdparty/postgresql/data/postgresql.auto.conf"
Thu 10 Nov 2016 04:11:00 PM CST 2016-11-10 08:10:55 GMT|0|FATAL:
database files are incompatible with server
Thu 10 Nov 2016 04:11:00 PM CST 2016-11-10 08:10:55 GMT|0|DETAIL: The
data directory was initialized by PostgreSQL version 9.2, which is not
compatible with this version 9.4.1.
Thu 10 Nov 2016 04:19:00 PM CST LOG: skipping missing configuration
file
"/var/opt/novell/sentinel/3rdparty/postgresql/data/postgresql.auto.conf"
Thu 10 Nov 2016 04:19:00 PM CST 2016-11-10 08:18:55 GMT|0|FATAL:
database files are incompatible with server
Thu 10 Nov 2016 04:19:00 PM CST 2016-11-10 08:18:55 GMT|0|DETAIL: The
data directory was initialized by PostgreSQL version 9.2, which is not
compatible with this version 9.4.1.


BR
Steve


--
steve_zeng
------------------------------------------------------------------------
steve_zeng's Profile: https://forums.netiq.com/member.php?userid=3875
View this thread: https://forums.netiq.com/showthread.php?t=56839