I just upgraded an environment running on SLES 11 SP4 that was IdM 4.0.3
and eDir 8.8 SP8 Patch 1 all the way up to IdM 4.5 SP5 and eDir 8.8 SP8
Patch 9. Now when any drivers that use KMOs from the vault start, I get
an error: java.io.IOException:
com.novell.nds.dirxml.driver.ssl.SSLInitialization Exception: Error while
creating KS from KMO for IDM-EDIR

Where IDM-EDIR is the KMO I created. I tried making new KMOs, but all
the drivers with KMOs throw this same error.

I raised the trace level to 10 on the eDir driver and I see this:


Code:
--------------------


[12/05/16 18:06:49.589]:ivdm ST:JSSEKMO: [KMO2Keystore] - Using KMO : \IDVAULT\core\IDM-EDIR - ividm
[12/05/16 18:06:49.589]:ivdm ST:JSSEKMO: [KMO2Keystore:readKMOFromIDV] - Created jclient context : Context=1930887269, epoch=1
[12/05/16 18:06:49.589]:ivdm ST:JSSEKMO: [KMO2Keystore:readKMOFromIDV] - Id resolution successful. Entry Id : 297947
[12/05/16 18:06:49.590]:ivdm ST:JSSEKMO: [KMO2Keystore:readKMOFromIDV] - Successfully read the KMO attributes from IDV
[12/05/16 18:06:49.590]:ivdm ST:JSSEKMO: [KMO2Keystore:readKMOFromIDV] - Initialized public key bytes..
[12/05/16 18:06:49.591]:ivdm ST:JSSEKMO: [KMO2Keystore:readKMOFromIDV] - Initialized private key bytes..
[12/05/16 18:06:49.591]:ivdm ST:JSSEKMO: [KMO2Keystore:readKMOFromIDV] - Freeing up the context.
[12/05/16 18:06:49.592]:ivdm ST:JSSEKMO: [KMO2Keystore:initPrivateKey] - Successfully unwrapped the secret.
[12/05/16 18:06:49.592]:ivdm ST:JSSEKMO: [KMO2Keystore:initPrivateKey] - cleaning up context.
[12/05/16 18:06:49.592]:ivdm ST:JSSEKMO: [KMO2Keystore:setupKeystore] - Initialized the keystore.
[12/05/16 18:06:49.593]:ivdm ST:JSSEKMO: [KMO2Keystore:setupKeystore] - keystore load completed.
[12/05/16 18:06:49.593]:ivdm ST:JSSEKMO: [KMO2Keystore:setupKeystore] - Instantiated certificate factory.
[12/05/16 18:06:49.595]:ivdm ST:JSSEKMO: [KMO2Keystore:setupKeystore] - Successfully setup the certificate chain.
[12/05/16 18:06:49.598]:ivdm ST:JSSEKMO: [KMO2Keystore:setupKeystore] - Cleaning up sensitive attributes.
[12/05/16 18:06:49.608]:ivdm ST:Restoring operation data to output document
[12/05/16 18:06:49.608]:ivdm ST:SubscriptionShim.execute() returned:
[12/05/16 18:06:49.608]:ivdm ST:
<nds dtdversion="4.0">
<source>
<product instance="eDirectory Driver" version="4.5.5.0">Identity Manager Driver for eDirectory</product>
<contact>NetIQ Corporation</contact>
</source>
<output>
<status event-id="ividm#20161205204217#1#1:91a0b92e-82c1-482d-6e8d-2eb9a091c182" level="retry" type="app-connection">java.io.IOException: com.novell.nds.dirxml.driver.ssl.SSLInitialization Exception: Error while creating KS from KMO for IDM-EDIR<operation-data>
<password-subscribe-status>
<association/>
</password-subscribe-status>
</operation-data>
</status>
</output>
</nds>



--------------------


I'm baffled. Any ideas?


Matt


--
matt
------------------------------------------------------------------------
matt's Profile: https://forums.netiq.com/member.php?userid=183
View this thread: https://forums.netiq.com/showthread.php?t=57024