All my agent have 11.3.1 with .net framework 4 . It's a system requirements for 11.3.1...

So why I have some client that have 11.3.1 and .net framework 4 that are unable to upgrade for this error :
[3236] [ZENUpdater] [] [SYSTEM] [SystemUpdate] [ERROR_CHECKING_PREREQUISITE] [ERROR] [.NET 4.0 is required but not found] [] [] [ZENworks]' was not found..

And this is the client registry :
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client]
"Version"="4.0.30319"
"TargetVersion"="4.0.0"
"Install"=dword:00000001
"MSI"=dword:00000001
"Servicing"=dword:00000000
"InstallPath"="C:\\Windows\\Microsoft.NET\\Framewo rk\\v4.0.30319\\"


Thanks,
Eyal