I am attempting to apply the Patch to my Filr Appliance.

First I run the preinstall-Filr-30SU1 patch, then when I run the patch install, the patch install fails with an error.

It appears that the preinstall patch updates the kernel such that makes it impossible for the patch complete successfully.

If I check the kernel-source before running the preinstall patch it reports

After the preinstall patch, the kernel-source reports

So looking in the install script shown below, it checks the kernel-source finds that it is and thus exits with an e

basekernel=$(rpm -qa kernel-source*)
if [ "$basekernel" != "kernel-source-3.0.101-84.1" ]; then
#Looks like they have not installed pre-install script
#throw_error will cause the UI to display an error message
#because this is not a valid command

Basically the preinstall patch updates the kernel-source and preventing me from applying the patch.

Does this mean that the preinstall patch is actually updating the kernel such that the doesn't need to be applied?