I'm having trouble opening the ESMWebStart from the Reporting Module
(/IDMRPT) Auditing settings. When I click the link and open the Event
Source Manager I get the Java splash screen. After a few seconds the
startup fails with 'Unable to launch the application'. On clicking
Details, the following error is visible


Code:
--------------------

com.sun.deploy.net.FailedDownloadException: Unable to load resource: http://ipaddress:8080/easwebstart/ESMWebStart.jnlp
at com.sun.deploy.net.DownloadEngine.actionDownload(U nknown Source)
.... and more at com.sun.x (Unknown Source)

--------------------


- Java version 1.8 64-bit (update 121) (on windows server with FireFox
in which I try to open ESM)
- Identity Apps 4.5.5 (linux)
- Reporting Module 4.5.3 (same server)
- eDirectory 8.8.8.9 (linux)
- EAS (linux)

What I tried and checked:
- Using JRE version 7 update 40 32-bit
- Saving the jnlp and starting it manually with javaws from both JRE's
- Check if port 10013 listening on the EAS server and open in the
firewall (and subsequently disable the iptables DROP rule just to be
sure)
- Check the jnlp for correct IP-address and port
- Check with browser if
http://ipaddress:8080/easwebstart/ESMWebStart.jnlp exists. It does, I
can download it from the browser
- Redeploy the easwebstart.war by deleting the easwebstart/ folder (and
removing temp and localhost folders)
- Restart EAS

Nothing worked. It seems to me that there is a problem opening the
sources from the Identity Apps server.

Any suggestions on how to get the ESM working?


--
Sjoerdk
------------------------------------------------------------------------
Sjoerdk's Profile: https://forums.netiq.com/member.php?userid=1135
View this thread: https://forums.netiq.com/showthread.php?t=57338