I'm looking at my SSPR portal and it is saying that I should enable Require HTTPS, which should be found under "Settings ⇨ Security ⇨ Web Security ⇨ Require HTTPS setting should be set to true for proper security" is the exact message. The thing is when I go to Settings - Security - Web Security there is no explicit Require HTTPS setting.

I've looked through the other options and read their descriptions but nothing jumps out at me as being the option to require https. I could still need some caffeine though, but what am I not seeing?