We are a Dell shop and the inventory taken by Zen 11.4.x was always good, values correct, etc. Now with ZENworks 2017 our inventory is getting more messed up with each pass of the ZEN inventory. We are a K-12 School District and have 17 different buildings, with 17 different subnets taking their inventory on a different day of the month (Building 1,subnet 1 inventory on the 1st of the month, so on and so on). The Dell models , Bios level, etc. are now being sourced from a different location in the registry.

As an example, BIOS info looks like it is now coming from - HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System | Value name: SystemBiosVersion | Value data: DELL - 1072009 BIOS Date: 11/01/16 03:45:36 Ver: A14.00
But not all of the Value data is being used as the ZEN Inventory shows : (DELL - 1072009-11/01/16)

It believe it used to come from - HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\BIO S | Value name: BIOSVersion | Value data: A14
- HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\BIO S | Value name: BIOSReleaseDate | Value data: 11/01/2016

A similar issue happens with the Dell Product type.

So if you try to run a report showing which Bios level you have on a given group of computers, you might end up with 15 different entries, some the new way some the old way. I am NOT a fan of the new way as it does not give you info that matches up with the way Dell labels their Bios upgrades.

Also on the ZENworks 2017 agent on the computer, the asset tag no longer appears, though it is still in the ZCC inventory.

My question to everyone that has upgraded... Are you seeing similar issues???

Thanks for listening!