Hi.
I have GMS Version: 14.2.1 Build: 289 installed.
My users use either Outlook 2013 or 2016 to connect to Mobility using Exchange activesync.

So every time Outlook is started the security alert pops up with the message "The name on the security certificate is invalid or does not match the name of the site."
Is there a way to disable this message? Or does I have do do something like get a paid SSL certificate?
I'd rather just have the message disabled if possible as everything is working fine.

Thanks!