It appears my Firefox browser updated recently and my remote management will not re-install. The previous version gave the same warnign message, but I was able to "Allow" it to run and use remote management on my Zenworks 11 SP4. After the Firefox update, all remote management stopped working and it tells me I need to install the Remote Viewer again. Any ideas how to fix? thanks