I finally was able to get my SSPR configured to use Twilio sms gateway trial account.

But when I do a "Forgotten Password" - the SMS token is HUGE. It must be over 100 characters in length.
I already checked Settings > SMS > SMS Gateway > Request ID Length and it's equal to 6

any ideas?

Thanks in advance