Hi,

I don't know if this is known problem or am I missing something obvious, but after IDM server upgraded to 4.6 (from 4.5.5) ecmascript ldapsearch stopped working.
Customer has null driver which does ldapsearch to local edirectory. ldapsearch fails with error:
com.novell.ldap.LDAPException: Connect Error

I've disabled ssl/starttls requirement on edirectory and tested with plain ldap over 389. Tried with server IP and loopback address, same result.
Tested openldap command and that worked:
Code:
ldapsearch -H ldap://127.0.0.1 -D <admin username> -w <adminpwd> -b '<base context>'  '<filter>' cn
To get more logs I've replaced ldapsearch with one from Lothar, and result was:
Code:
bh_LdapSearch: Preparing new plaintext connection.
bh_LdapSearch: Connecting to 127.0.0.1:389
bh_LdapSearch: Binding as user <admin username>
bh_LdapSearch: JavaException: com.novell.ldap.LDAPException: Connect Error
bh_LdapSearch: Disconnecting from server.

eDirectory ldap trace shows error "Invalid protocol request on connection":
Code:
2864256768 LDAP: [2017/07/04 14:40:44.61] New cleartext connection 0x137a1c00 from 127.0.0.1:59318, monitor = 0x843b9700, index = 8
2218497792 LDAP: [2017/07/04 14:40:44.64] Invalid protocol request on connection 0x137a1c00
2218497792 LDAP: [2017/07/04 14:40:44.64] Monitor 0x843b9700 initiating close for connection 0x137a1c00
2081564416 LDAP: [2017/07/04 14:40:44.65] Server closing connection 0x137a1c00, reason = 2
What am I missing?

regs s