Is anybody else having any luck imaging a 7280?

I've tried the latest imaging update (March), adding the newid to the pxe boot, without luck. I've also tried downloading the latest linux driver from intel and compiling the ko file with SLES 11 SP (3.0.101-63-default) and inserting that to the initrd (for both pxe and bootcd), which again failed with flying colours.

The boot cd gets to the point where it is loading the e1000e and then is just seems to hang.
The pxe boot gets to the point where it is loading the driver and then it goes to the red and blue OS install screen saying "Could not find the ZENworks Repository".

The instructions I am using to compile the driver into initrd (for pxe) are:

  1. Use a current Zenworks Imaging CD to get to a command prompt on the computer
  2. hwinfo --netcard
  3. Record the "Vendor" and "Device" information (ie. 0x14e4 0x1692)
  4. Download the linux driver from the vendor (ie Broadcom)
  5. Start a VM with SLES11SP4, for Zenworks Imaging v11.3.2
  6. Ensure that the gcc devel files and the kernel source files are installed
  7. Create the directories /tmp/package, /tmp/package/work, /tmp/package/driver
  8. Copy the driver download to /tmp/package/drive
  9. Copy \\<server>\srv\tftp\boot\initrd to /tmp/package
  10. Extract the driver
    tar -xvzf <filename>
  11. Cd into the directory with the Makefile file
  12. make clean
  13. make
  14. You should now have a .ko file in the directory (ie tg3.ko)
  15. cd /tmp/package
  16. mv initrd initrd.gz
  17. gunzip initrd.gz
  18. cd work
  19. cpio -idmuv < ../initrd >/dev/null 2>&1
  20. Edit linuxrc.config to add in the new nic
    (ie newid=0x14e4 0x1692,tg3)
  21. cp <path>/<filename>.ko /tmp/package/work/lib/modules/2.6.27.29-0.1-default/initrd
  22. cd /tmp/package/work
  23. find . | cpio --quiet -o -H newc > ../initrd
  24. cd ..
  25. gzip -v9c initrd > initrd.gz
  26. Copy initrd.gz back to \\<server>\sys\tftp\boot\
  27. Delete the old initrd and rename initrd.gz to initrd


thanks