Just confirmed. It works flawlessly with Fedora 26 x64. Just install prequsites:

glib2.i686
compat-libstdc++-33.i686
pcre.i686
gtk2.i686
pam.i686
compat-libstdc++-33.i686
nici
nici.i686

And fire designer install.