Hello,
I upgraded to ZENworks 2017 Update 1 last week and encounter a problem while trying to register new Windows 7 SP1 machines. After downloading the ZENworks agent from the ZCC the agent could be installed. However the machine wasn´t registered.
I used the following command to register, but got an error saying the IP address is invalid. Very strange, because the IP address does not belong to any ZENworks server or a machine, with a ZENworks agent.
C:\Windows\system32>zac reg -g https://zcmp1.rz.xyz.de
Processing Command: reg
Username: myname
Password: **********

Unable to register with the server at: https://zcmp1.rz.xyz.de.
RegistrationManager - Protocol error from server: Unhandled Server Exception;
nested exception is:
java.lang.IllegalArgumentException: At least one IP address is invalid.
Input IP addresses = 193.196.xxx.xxx, 187

After all I tried to register with a registration key and this worked fine.
But I want to register the machine while installing the agent like before (ZCM11.3.2). Any help is appreciated.

Karin