Home

Results 1 to 5 of 5

Thread: ZENWorks 2017 Update 1 never starts upgrade on prime servers

  1. #1
    Join Date
    Oct 2009
    Posts
    85

    ZENWorks 2017 Update 1 never starts upgrade on prime servers

    Last night at midnight, I attempted to assign the update to my primary servers. It had downloaded as a system update and replicated to both servers already. My understanding is that unlike former updates, this one can be assigned directly to my primary servers from System Update.

    I assigned it to both servers as install "now" and opened the status webpage for updates. I ran a zac zeus-ref, zac ref, even restarted the services on both servers multiple times over the course of 90 minutes and nothing happened. The status never changed. I saw no activity on the servers. There weren't even log directories for the update guid created. Eventually I just removed the updates as I didn't want anything weird to happen that I wasn't going to be aware up. Everything seemed fine at the time and I got some sleep. Then about 2 hours later at around 3 am, both servers became unresponsive. The zen-server and zen-loader services crashed. After I brought the services backup up this morning at 6 am I checked the diagnostics page and doing so immediately crashed the services on the servers. Rebooting didn't seem to help much either. Luckily I created snap shots before I attempted the update of my database server and both primaries. I reverted to those snapshots and everything was fine again.

    I checked my disk space. My upgrades to 2017 went fine just 6 weeks ago. I expected this to go even smoother. Anyone else having issues getting the updates to kick off? Hints or help are welcome.
    Regards -- Chad

  2. #2
    Join Date
    Oct 2009
    Posts
    85

    Re: ZENWorks 2017 Update 1 never starts upgrade on prime ser

    Oh I also tried assigning it to only one primary server at a time as well.
    Regards -- Chad

  3. #3
    Join Date
    Feb 2008
    Location
    Raleigh, NC
    Posts
    6,658

    Re: ZENWorks 2017 Update 1 never starts upgrade on prime ser

    Well assigning directly to Primary Servers is not really different from prior System Updates.
    ISO/Media releases tend to require the use of Media to upgrade them.
    Smaller DOT releases that do not have matching ISO releases have always been deployed via System Update.

    Are Both Primary Servers in the Same Physical Location?
    Are you sure the ZCM Services "Crashed" vs "Stopped"?
    ZCM 2017 will Start/Stop the ZCM services across all primaries as necessary to do an upgrade.
    Upgrading the first will require services on all servers to be stopped until it is complete.

    The reason I asked about Physical Location is that they should be at the same spot but if they are not.....
    It is possible the ZEUS agent on the primaries may not have been pulling from the correct local server....
    The ZEUS agent does not install directly from the Content-Repo, but downloads it and installs.
    Possibly this process was taking an excessive time, which is why you saw the delay....
    The only reason I can think of for an excessive delay is pulling from wrong primary and one being over a WAN.

    Keep in mind.......I have limited data so I'm forced to guess...............
    --
    Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or may not be shared by Micro Focus or any Sane Person
    Please Use at your Own Risk.

    Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

    https://ideas.microfocus.com/mfi/novell-zcm

    Want to Turbo charge your apps and put an end to compatability issues?
    https://www.microfocus.com/products/...top-containers

  4. #4
    Join Date
    Oct 2009
    Posts
    85

    Re: ZENWorks 2017 Update 1 never starts upgrade on prime ser

    Yes. Same location same network so I would expect no delays from that. Given that no deployments had even started, I doubt that they were "stopped". As there were not even the log guid directories created, I don't have any log files to look at or share. But the fact that it seemed to run fine for a while and crashed every time I opened the Diagnostics screen makes me think something else may have been happening. I will make new snapshots and try it again tomorrow night.
    Regards -- Chad

  5. #5
    Join Date
    Feb 2008
    Location
    Raleigh, NC
    Posts
    6,658

    Re: ZENWorks 2017 Update 1 never starts upgrade on prime ser

    Make sure you have PLENTY of disk space....
    The Docs really underestimate the amount of disk space required.....

    "zman sudu" can delete old system updates which can stick around sort of hidden.
    Old "Superseded" files can be removed.....
    --
    Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or may not be shared by Micro Focus or any Sane Person
    Please Use at your Own Risk.

    Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

    https://ideas.microfocus.com/mfi/novell-zcm

    Want to Turbo charge your apps and put an end to compatability issues?
    https://www.microfocus.com/products/...top-containers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •