In the past, we've had issues with SSL communication between different versions of the IDM engine and the remote loader, due to security fixes and such. My understanding is the versions don't necessarily have to be the same unless there is something like an SSL fix but we try to keep them on the same version. It doesn't always happen for one reason or another. I am trying to connect an AD RL (4.6) to IDM 4.5.5. I see in the documentation that there should be issues between 4.5.3 and 4.6 but nothing about 4.5.5. This is the error I'm getting:

SSL protocol failure: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

Any ideas on where to look next. The certificate should be correct but certs are admittedly not my strongest subject.