Hi

I need to connect a REST driver to two different endpoints. One endpoint is the actual application where the users are created.
The other endpoint is where I fetch a session token to use when i want to communicate with the application.

According to the documentation it should be possible to have a url parameter in the operation data, but it does not seems to be used.
Code:
<request method="put" url="https://172.16.0.0:XXXX/User/rest123">
Trace example, where the url parameter gets appended the base url.
Code:
[09/26/17 15:56:23.672]:SensumSSOTest ST:            Submitting document to subscriber shim:
[09/26/17 15:56:23.672]:SensumSSOTest ST:            
<nds dtdversion="4.0" ndsversion="8.x">
  <source>
    <product edition="Advanced" version="4.6.1.0">DirXML</product>
    <contact>NetIQ Corporation</contact>
  </source>
  <input>
    <driver-operation-data class-name="Token" command="query" event-id="0" src-dn="">
      <request method="POST" url="https://THISISAUTHSITE">
        <url-token/>
        <header Accept="application/json" X-Version="1" content-type="application/json;charset=UTF-8"/>
        <value>{}</value>
      </request>
    </driver-operation-data>
  </input>
</nds>
[09/26/17 15:56:23.673]:SensumSSOTest ST:            SensumSSOTest: sub-execute
[09/26/17 15:56:23.673]:SensumSSOTest ST:            SensumSSOTest: queryHandler
[09/26/17 15:56:23.673]:SensumSSOTest ST:            SensumSSOTest: queryHandler: class-name  == 'Token'
[09/26/17 15:56:23.673]:SensumSSOTest ST:            SensumSSOTest: Query: preparing POST to https://THISISAPPSITE/test_bsk/https://THISISAUTHSITE/auth_test/wsapi/authentication/external/sessions
[09/26/17 15:56:23.673]:SensumSSOTest ST:            SensumSSOTest: Setting the following HTTP request properties:
 Authorization: <content suppressed>
[09/26/17 15:56:23.673]:SensumSSOTest ST:            SensumSSOTest:  content-type:application/json;charset=UTF-8
[09/26/17 15:56:23.673]:SensumSSOTest ST:            SensumSSOTest:  Accept:application/json
[09/26/17 15:56:23.673]:SensumSSOTest ST:            SensumSSOTest:  X-Version:1
Have tried with https:// in base url and then the rest of the url on the different resources, but that does not work either. The call actually seems ok.

Code:
  <source>
    <product edition="Advanced" version="4.6.1.0">DirXML</product>
    <contact>NetIQ Corporation</contact>
  </source>
  <input>
    <driver-operation-data class-name="Token" command="query" event-id="0" src-dn="">
      <request method="post" url="https://THISISAUTHSITE/auth_test/wsapi/authentication/external/sessions">
        <url-token/>
        <header Accept="application/json" X-Version="1" content-type="application/json;charset=UTF-8"/>
        <value>{}</value>
      </request>
    </driver-operation-data>
  </input>
</nds>
[09/26/17 14:31:18.304]:SensumSSOTest ST:            SensumSSOTest: sub-execute
[09/26/17 14:31:18.304]:SensumSSOTest ST:            SensumSSOTest: queryHandler
[09/26/17 14:31:18.304]:SensumSSOTest ST:            SensumSSOTest: queryHandler: class-name  == 'Token'
[09/26/17 14:31:18.304]:SensumSSOTest ST:            SensumSSOTest: Query: preparing POST to https://THISISAUTHSITE/auth_test/wsapi/authentication/external/sessions
[09/26/17 14:31:18.305]:SensumSSOTest ST:            SensumSSOTest: Setting the following HTTP request properties:
 Authorization: <content suppressed>
[09/26/17 14:31:18.305]:SensumSSOTest ST:            SensumSSOTest:  content-type:application/json;charset=UTF-8
[09/26/17 14:31:18.305]:SensumSSOTest ST:            SensumSSOTest:  Accept:application/json
[09/26/17 14:31:18.305]:SensumSSOTest ST:            SensumSSOTest:  X-Version:1
[09/26/17 14:31:18.305]:SensumSSOTest ST:            SubscriptionShim.execute() returned:
[09/26/17 14:31:18.306]:SensumSSOTest ST:            
<nds dtdversion="3.0">
  <source>
    <product build="20170208_1048" version="1.0.0.1">Identity Manager REST Driver</product>
    <contact>NetIQ Corporation.</contact>
  </source>
  <output>
    <status event-id="0" level="fatal" type="app-authentication">ClientProtocolException: URI does not specify a valid host name: https:/</status>
Has anyone tried something similar ?

/Kristoffer