The doc say you cannot upgrade to 4.6 from earlier versions than 4.5.

I am curious. That must be referring to the User App/Identity Apps.

The engine as far as I can tell, could care less.

Engine wise, it should not matter at all.

Am I missing something?