I am attempting to connect to our Vibe instance with the desktop client for the first time and this is the error I am seeing in the log file on the client I am using:

Code:
2017-11-30 11:01:55,051 [ui-1] [INFO] Requesting / REST resource (GET)... (aca.onprem.apiserver.restapi)
2017-11-30 11:01:56,841 [ui-1] [INFO] Completed request for / REST resource (GET) (aca.onprem.apiserver.restapi)
2017-11-30 11:01:56,841 [ui-1] [ERROR] Exception: <class 'aca.excepts.OpenSSLError'> (aca.excepts)
Traceback (most recent call last):
  File "aca\onprem\auth.pyo", line 606, in _apply
  File "aca\onprem\apiserver.pyo", line 483, in VerifyServerInformation
  File "aca\onprem\restapi.pyo", line 229, in VerifyAuthorization
  File "aca\onprem\restapi.pyo", line 144, in GetReleaseInfo
  File "aca\onprem\restapi.pyo", line 137, in GetUriFromRoot
  File "aca\onprem\restapi.pyo", line 130, in GetApiRoot
  File "aca\onprem\restapi.pyo", line 169, in MakeJSONRESTRequest
  File "aca\onprem\restapi.pyo", line 205, in MakeRESTRequest
  File "aca\net\http.pyo", line 203, in MakeBasicAuthRequest
  File "aca\net\http.pyo", line 138, in MakeRequest
  File "urllib2.pyo", line 431, in open
  File "urllib2.pyo", line 449, in _open
  File "urllib2.pyo", line 409, in _call_chain
  File "aca\net\http.pyo", line 299, in https_open
  File "urllib2.pyo", line 1194, in do_open
  File "aca\net\http.pyo", line 364, in request
  File "httplib.pyo", line 1001, in request
  File "httplib.pyo", line 1035, in _send_request
  File "httplib.pyo", line 997, in endheaders
  File "httplib.pyo", line 850, in _send_output
  File "httplib.pyo", line 812, in send
  File "aca\net\http.pyo", line 481, in connect
OpenSSLError: Error([('SSL routines', 'SSL3_READ_BYTES', 'tlsv1 alert internal error')],)
Any idea what I am doing wrong? My guess is that there is something with the SSL handshake.

Thanks!