As Laura says, newer clients cannot connect to older systems. Another "oddity" this time with GW 18 is that you can use the new GMS on a GW 2014 and newer PO, but the domain must first be upgraded to GW 18.