Yes, I know, UserApp 4.02 is old, out of support, etc.. Should be upgraded, but will not be. That''s a long story, just assume that no UserApp upgrade will be happening.

I have a UserApp here that is configured to log to a Sentinel system. Sentinel has been upgraded to 8.1, and the Java security settings in Sentinel block the certificate used by the UserApp's platform agent (512-bit RSA/MD5). I've used TIDs 7017764 and 7014219 to modify Sentinel's Java security to get events flowing, which works, but will fail in the future when Sentinel upgrades Java and replaces the security settings again.

Is it possible to upgrade / replace the audit platform agent in UserApp with something newer using a new certificate?