Hi,

After upgrade to UserApp 4.6.2 workflow notifications are not send any more. There is a problem with:

2018-02-06 13:00:37,023 [ERROR] UserActivity [RBPM] Error generating URL used in template.
com.novell.soa.notification.impl.NotificationExcep tion: Error generating URL used in template.
at com.novell.soa.af.impl.core.WorkflowNotification.s end(WorkflowNotification.java:318)
at com.novell.soa.af.impl.activity.UserActivity.sendN otificationToDefault(UserActivity.java:1421)
at com.novell.soa.af.impl.activity.UserActivity.sendN otification(UserActivity.java:1382)
at com.novell.soa.af.impl.activity.UserActivity.sendN otificationEmail(UserActivity.java:1164)
at com.novell.soa.af.impl.activity.UserActivity.notif yArrive(UserActivity.java:419)
at com.novell.soa.af.impl.core.ProcessImpl.startActiv ity(ProcessImpl.java:1706)
at com.novell.soa.af.impl.core.ProcessImpl.forward(Pr ocessImpl.java:1603)
at com.novell.soa.af.impl.activity.ActivityNode.forwa rd(ActivityNode.java:265)
at com.novell.soa.af.impl.activity.ActivityNode.forwa rd(ActivityNode.java:240)
at com.novell.soa.af.impl.activity.MappingActivity.pr ocess(MappingActivity.java:68)
at com.novell.soa.af.impl.activity.ActivityNode.notif yArrive(ActivityNode.java:206)
at com.novell.soa.af.impl.activity.RunnableActivity.r un(RunnableActivity.java:50)
at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.NullPointerException
at com.novell.soa.af.impl.core.WorkflowNotification.s end(WorkflowNotification.java:313)
... 14 more

Before upgrade everything was fine.

After increasing log level for com.novell.soa.af.impl , com.novell.soa.notification.impl , com.novell.soa.notification.impl.vdx nothing else occur what could lead to generating this error.

Anyone had the same issue? I would appreciate any help.