Updated customer to 2017 Update 2.
Mixed enviroment with Win7 and Win 10.
Most of the devices running agent 11.4.x.
Starting to deploy new agent the normal way via Configuration/SystemUpdate.
Update gets assignd, and I refresh agent on device to get in to start.
On Win 7 -machines it works as it always have. After a short while, the update starts, and works fine.
On the Win 10 machines the update never starts. I try to do refresh many times but it wont start. Same procedure on Win 7 starts fine. ZCC says "Update assigned" and that a refresh needs to occur.
After long time, I try to choose "Check for updates" from systemtray. Wheel starts to spin and does it forever. No change.
Restarts machine to get rid of spinning wheel after "Check for update".
Refresh, wait. Nothing.
Then test to take up cmd. Running zac zeus-ref.
Then I get:
C:\>zac zeus-ref
System.ComponentModel.Win32Exception (0x80004005): Det gr inte att hitta filen
vid System.Diagnostics.Process.StartWithCreateProcess( ProcessStartInfo startInfo)
vid System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
vid Novell.Zenworks.Zmd.Zeus.ZeusCommandTriggerer.Star tZeusInvoker(ProcessStartInfo cmdToRun)
vid Novell.Zenworks.Zmd.Zeus.ZeusCommandTriggerer.Run( String[] args)
vid Novell.Zenworks.Zmd.Zeus.ZeusCommandLineHandler.Ha ndle()
vid CommandLineExe.Program.HandleAndExitIfZeusRelated( String[] args)
vid CommandLineExe.Program.ProcessArgs(String[] args)
vid CommandLineExe.Program.Main(String[] args)

Those machines will never start upgrade.
But... Exact same agent, running on Win 7, starts upgrade perfect.
Agent version is: 11.4.3.23202.
Windows 10 is mostly 1607.

Strange this is, that I have had some Win 10 machines, that have started to upgrade after a zac zeus-ref. Unfortunalty I cannot tell what exact version of agen were on those machines.
On those machines that have worked, the machine says "Explorer needs to be restarted" and waits for OK from user.
Doing that starts the upgrade.

Have tested on my test-environment.
Same problem there. Win 10 with 11.4.3 -agent does not start update.
Win 10 machine with 2017.0 starts update fine to 2017.2.

Anyone seen this?
Read some threads that the Explorer-restart had been a problem in 2017.0.and 2017.1 and that it should be solved to 2017.2. But it seems not.
And why does not zac zeus-ef work on 11.4.3.23202.
And for those who work, why the need for a zac zeus-ref just to trigger the start?
I will test some more.
Ideas, anyone?
/Stefan