When we attempt to update the messenger 3.03 client to the gw messenger 2018 client I can't avoid a dialog about repairing or removing the existing software. Has anyone found a way to make it work?

It appears there's no way to distinguish the versions or to allow overwrite of the software. I guess it means there's little to no discernable difference in the client except colorscheme and branding.