Hi!

I am installing NetIQ Identity Manager 4.6 on a Red Hat 7 server and, for the most part, the installation as gone flawlessly. But when starting Tomcat for the Identity Applications, I see the following errors in idapps.out:
2018-03-13 13:46:28,272 [ERROR] EboBootServlet [RBPM] Runtime exception initializing.
com.netiq.persist.PersistenceException: org.hibernate.HibernateException: Could not find datasource
at com.netiq.persist.HibernateUtil.getSessionFactory( HibernateUtil.java:94)
at com.netiq.persist.HibernateUtil.getCurrentSession( HibernateUtil.java:167)
at com.novell.soa.persist.DatabaseSchemaUpdate.valida teDatabaseSchema(DatabaseSchemaUpdate.java:199)
at com.sssw.fw.servlet.EboBootServlet.init(EboBootSer vlet.java:98)
at com.sssw.portal.servlet.EboPortalBootServlet.init( EboPortalBootServlet.java:58)
at javax.servlet.GenericServlet.init(GenericServlet.j ava:158)
at org.apache.catalina.core.StandardWrapper.initServl et(StandardWrapper.java:1183)
at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1099)
at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:989)
at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:4913)
at org.apache.catalina.core.StandardContext.startInte rnal(StandardContext.java:5223)
at org.apache.catalina.util.LifecycleBase.start(Lifec ycleBase.java:150)
at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:752)
at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:728)
at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:734)
at org.apache.catalina.startup.HostConfig.deployWAR(H ostConfig.java:952)
at org.apache.catalina.startup.HostConfig$DeployWar.r un(HostConfig.java:1823)
at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.jav a:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.hibernate.HibernateException: Could not find datasource
at org.hibernate.connection.DatasourceConnectionProvi der.configure(DatasourceConnectionProvider.java:79 )
at org.hibernate.connection.ConnectionProviderFactory .newConnectionProvider(ConnectionProviderFactory.j ava:143)
at org.hibernate.connection.ConnectionProviderFactory .newConnectionProvider(ConnectionProviderFactory.j ava:84)
at org.hibernate.cfg.SettingsFactory.createConnection Provider(SettingsFactory.java:459)
at org.hibernate.cfg.SettingsFactory.buildSettings(Se ttingsFactory.java:91)
at org.hibernate.cfg.Configuration.buildSettingsInter nal(Configuration.java:2833)
at org.hibernate.cfg.Configuration.buildSettings(Conf iguration.java:2829)
at org.hibernate.cfg.Configuration.buildSessionFactor y(Configuration.java:1840)
at com.netiq.persist.HibernateUtil.getSessionFactory( HibernateUtil.java:92)
... 21 more
Caused by: javax.naming.NamingException
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:856)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:159)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:827)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:173)
at org.apache.naming.factory.ResourceLinkFactory.getO bjectInstance(ResourceLinkFactory.java:152)
at javax.naming.spi.NamingManager.getObjectInstance(N amingManager.java:321)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:839)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:159)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:827)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:159)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:827)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:159)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:827)
at org.apache.naming.NamingContext.lookup(NamingConte xt.java:173)
at org.apache.naming.SelectorContext.lookup(SelectorC ontext.java:163)
at javax.naming.InitialContext.lookup(InitialContext. java:417)
at org.hibernate.connection.DatasourceConnectionProvi der.configure(DatasourceConnectionProvider.java:75 )
... 29 more

To troubleshoot I have done the following:
- I've tried changing the hostname of the database server in server.xml
- I've tried changing the username and password in server.xml
- I've verified the connection settings using pgAdmin
- I have compared the settings in server.xml on the Red with the settings in server.xml on a SuSE server

Is there anything else I can check?


Ragnar StorstrÝm