Question about enrolling mac os with DEP devices (high sierra atm)

This is what i found, and no, mac os is not mentioned there, https://www.novell.com/documentation....pdf#b1826u672
"ZENworks supports devices running on Android 4.1 and newer, and devices running iOS version
8 and newer. Also, ZENworks supports devices running ActiveSync 12.1 and newer."

So i'm guessing it's not supported, but is it perhaps being addressed soon?

Zenworks seems to see these devices as "iOS-10.13.3" at the time of writing. (high sierra with a small update)
Sometimes it works to enroll them and sometimes they get stuck in pending devices, i've also tried wiping them via unenroll, sending command to them has never worked so far.

It does however seem to see the model correctly, serial number etc etc.
I'm assuming there is *some* functionallity incorporated, either that or it's similar enought to ios as to work that far.

We are running zenworks 2017 update 2.