I got a real odd one here. Started getting reports that admins trying to set user passwords in iManager were getting -632 errors and the passwords would not set.
So I took a look and watched NMAS trace and I see this:

ERROR: -16050 GetXKeyFromValues: DAL_getValueData (key)
ERROR: -16050 Failed set password for CN=XXXXXXX

It's not clear to me what that error means. So I used rmupwd and removed the user's universal password, which said it was successful.
But I still get the same error when I try and set the user's password.

So I created a new password policy, just a basic one, and assigned the user to it. Same problem.

No matter what I do, I cannot set passwords for several users. They all get this same error.

The tree is all eDir 9.1.1 (1 SLES and 3 RedHat servers).

I thought maybe there was an odd NMAS issue going on so I removed all the old/obsolete login sequences and methods (this tree has been around a long long time).

I also checked the SDI Tree key with sdidiag and it looks fine, all 4 servers are key server and all 4 have all the keys.

I also ran local DB repairs on each server, nothing but a few object timestamp errors.

I'm stumped.

Any ideas?