I've been asked to sort out a OES11 Server setup in 2012

Server Motherboard died and out of desperation
After cloning the disk with a Hardware clone I tried in a new machine
Grub Splash screen loads but can't find device
I know that's normal for SATA disk in a new machine

I tried OES11 Sp1 disk > repair option with one of the disk
but it says its NOT the correct version!!
I went ahead anyway but can't repair because of partioning

Same with SP2 - so I'm guessing its pre SP1 & don't have the disk for that!

I tried removing RAID setup by stopping MD0 & MD1 & zeroing superblock (never done anything with software raid so I'm relying on google !)
I can mount the /dev/sda2 and see the data

I also DD copied /dev/sda using same partitions (using SFDISK)
again I can mount /dev/sda2

Managed to get the most of the data off BUT would like to boot the Server in another box
They have some custom software which required a key to make the data useable!
They have CD for the software but can't install again without generating a un-install key - so bit screwed
(the company that did the software no longer around) ... hence OES11 still

Any ideas how I can boot the Server
maybe server still thinks its RAID1 - even though I've removed disk from RAID

I don't really understand madam config
may be need to re-do init ??

Any ideas would appreciated