I have 3 SLES 12 SP4 servers running eDir 9.1.2. On two of them, SSL connections using tools like curl and wget work fine, but on the 3rd server, I get errors like this:

curl https://www.google.com
curl: /opt/novell/lib64/libssl.so.1.0.0: no version information available (required by /usr/lib64/libcurl.so.4)
curl: /opt/novell/lib64/libcrypto.so.1.0.0: no version information available (required by /usr/lib64/libcurl.so.4)
curl: (60) SSL certificate problem: unable to get local issuer certificate

So I did ldd /usr/bin/curl and I see that libssl and libcrypto are pointing at the Novell versions for some reason:

libssl.so.1.0.0 => /opt/novell/lib64/libssl.so.1.0.0 (0x00007fca1f438000)
libcrypto.so.1.0.0 => /opt/novell/lib64/libcrypto.so.1.0.0 (0x00007fca1df34000)

on the working servers, I see this:

libssl.so.1.0.0 => /lib64/libssl.so.1.0.0 (0x00007fc6d9365000)
libcrypto.so.1.0.0 => /lib64/libcrypto.so.1.0.0 (0x00007fc6d8efe000)


I can't for the life of me figure out how to fix this (no symlinks that I can find, no path issues that I can see). I've force reinstalled the OpenSSL and libopenssl RPMs. I've tried force reinstall eDir too.

I did open an SR, but SuSE supports says it is a NetIQ issue and NetIQ says it is a SuSE issue. Neither has offered much in the way of suggestions to fix this.

There must be a way though to correct this? I figured I'd try here in the eDir forum first.

Short of rebuilding the server, any ideas?

Thanks!

Matt