SPF record and outside network email client


I have a gwava appliance setup as a middle man between our GroupWise server and the world. The problem is we just created an SPF record and now email clients (outside the network) are getting a send failure problem. Is there an option that when someone authenticates through the Gwava appliance to our mail server that it will accept the mail?
We have the "SMTP relay agent target server" setup under "Configure Server" with our GroupWise server and under the configure domains setup with our GroupWise server under the "SMTP server" list with "Receive mail/Authenticate".
I'm not sure what I'm missing and any direction would help.

Here is what's in the smtp log in gwava
[2r7e4gg][2] FEB-07 15:24:18 TLS started for connection with xxx.xxx.xxx.xxx
[2r7e4gg][2] FEB-07 15:24:19 Auth Login for: (mylogin@domain)
[2r7e4gg][2] FEB-07 15:24:19 Connecting to (our groupwise server), for (our groupwise server)
[2r7e4gg][2] FEB-07 15:24:19 Connected to server (our groupwise server) on port 25
[2r7e4gg][2] FEB-07 15:24:20 Received 504 byte message (16 lines)
[2r4lmrg][1] FEB-07 15:24:21 GWAVA scan started from SMTP thread: [2r7e4gg]
[2r4lmrg][2] FEB-07 15:24:21 GWAVA reports message should be blocked
[2r7e4gg][2] FEB-07 15:24:21 Message was blocked: spf
[2r7e4gg][1] FEB-07 15:24:23 Socket is closed
[2r7e4gg][1] FEB-07 15:24:23 => Socket write error: socket unavailable
[2r7e4gg][1] FEB-07 15:24:23 <= Socket read error: socket unavailable
[2r7e4gg][2] FEB-07 15:24:23 Client disconnected from xxx.xxx.xxx.xxx


Mail client message.
An error occurred while sending mail. The mail server responded: Message was blocked by server (GWAVA blocked: spf, reference ID: str=0001.0A020207.5C5CA52E.0052,ss=1,re=0.000,recu =0.000,reip=0.000,cl=1,cld=1,fgs=0). Please check the message and try again.