On 08-02-19 13:54, mdymes wrote:
>

I was able to restart the print manager /
> Driver Store / Apache / Tomcat and get everything up and running. The
> last 2 times, I could not get it back.



Why not? What error did you get in ipsmd.log?
Change ipsmd log from warning to info in
/etc/opt/novell/iprint/conf/iprintconf.properties

server_log_level=info

That will show more info when ipsmd is starting



> The Following things have been done.
>
> 1st attempt - Usual OES tricks, Updates, Certificate recreation script,
> common proxy fix, reboots - This worked for about 2 weeks
> 2nd attempt - Move the IDSD daemon from the 1st print manager server to
> the second, shut down the driver store on the first - this worked for
> about 2 weeks as well
>
> Current attempt (work done last night) - Spin up a new OES 2018 server,
> Setup the Driver store on this server, copy all drivers to it. Point
> the 2x print managers to this for Drivers and shut down the existing
> Driver stores.
> Followed TID Document ID
> https://support.microfocus.com/kb/doc.php?id=3484700 - Reset the modipp
> folder on both print managers -
> Added novell-idsd as a monitored process to my zenoss setup
>
> When the problem occurs, I have very little breadcrumbs to follow.
> Journalctl shows nothing, apache logs do not have anything outstanding
> that I can tel



When problem occurs:

1. Enable ipptrace on the client. Tid7007023
2. Install wireshark and start capturing
3. install the supportutils-plugin-iprint-3.1.0-0.noarch.rpm if not yet
installed on server
4. Duplicate the problem when trying to print
5. Once problem arise, stop lan trace, go to server and type (case
sensitive):

# iPrintInfo -b

authenticate using an user with admin rights in FDN in dot format. It
will create an iprint info txt file.

With the info in the lan trace, the c:/ndps directory and the iprint
info txt file should be enough info to see why it fails