Good Day,

We are having to use signed certificates as opposed to self-signed certificates. In iManager I created the .CSR and provided it to our Security Department to do the signing. At the end I was provided with :


$ file 01-server.csr
01-server.csr: RFC1421 Security Certificate Signing Request, ASCII text, with CRLF line terminators


$ file 02-server.pem
02-server.pem: PEM certificate

Chain & Root Certificate

$ file 03-LAWtrustPrivateTLSCA01.crt
03-LAWtrustPrivateTLSCA01.crt: PEM certificate

$ file 04-LAWtrustPrivateRootCA.der
04-LAWtrustPrivateRootCA.der: data

Now I tried to import the signed certificate but get the following error :

PKI Error -1226 A certificate was not found in the NDS tree certificate authority (CA) object or Server Certificate Object (also known as the Key Material Object).

Converted .pem to .der and same error. I then created the Trusted Roots Container and added the following there :

$ file 04-LAWtrustPrivateRootCA.der
04-LAWtrustPrivateRootCA.der: data

Tried importing the signed certificate again but the same error.

Note that I am using the latest 2.x iManager and latest plugins.

What am I missing ?