On several Dell models such as the OptiPlex 5060, Latitude E5450 and 5490 computers we are getting errors when computers are flagged to image that the "Imaging operation failed. Could not connect to server." However the computer just communicated with the server to see it was flagged for imaging work and the boot.sdi and winpe.wim files were downloaded. If I boot into maintenance mode and check for imaging work, sometimes I get the error, other times it begins to run the preboot script. I may also have to flag the computer again then check for imaging work once in WinPE maintenance mode for it to image. However in every case I can exit "zenworktodo.exe" and ping the imaging server from the cmd window and it gets a reply from the imaging server. So I don't understand why imaging is hit and miss. I first noticed this problem more often when I modified winpe.wim with NIC drivers for the Microsoft LAN adapter so I can image Surface Pro's. The original winpe.wim file only had the Inel I219V NIC driver for OptiPlex 5060's. I thought the two NIC drivers could be causing conflicts so I copied the original wim files with only the OptiPlex 5060 NIC drivers back to the server thinking the problem would be solved. However even after reverting to the previous winpe.wim files I still get the "could not connect to server" error more often than not. Our winpe.wim file contains the following additions:
Intel I219V (64-bit NIC driver for OptiPlex 5060's

Any idea why zenworktodo.exe cannot consistently communicate with the imaging server?