I was able to get it fixed. While technically the error still occurs (protected field, etc.), it was the fact it "held" my keyboard til I hit escape that was an annoyance.

The setting I changed was:

Terminal Configuration >> Terminal Settings >> Input (section) >> Keyboard Error >> Select "Auto reset when a keyboard error occurs"