Hello,

We are currently running on IDM 4.7.2, eDir - 9.1.2, SSPR - 4.3.0.4, OSP - 6.3.1 on RHEL 7.6. SSPR public url's works fine but when trying to access SSPR private url's brings up blank screen on the browser.
When observed OSP logs, character F is not being removed from sspr/public/oauth url. Checked ism-configuration file and SSPRConfiguraiton.xml files.

OSP Log:


Preamble: [OIDP]
Priority Level: SEVERE
Java: internal.osp.oidp.service.oauth2.handler.RequestHa ndler.respondWithPageError() [582] thread=https-jsse-nio-8443-exec-11
Time: 2019-05-14T14:31:36.678-0400
Log Data: Code: internal.osp.oidp.service.oauth2.handler.HandlerEx ception.<init>() [183]
Text: Client-supplied redirect URI is not registered: https://www.inet.jnet.beta.pa.govFsspr/public/oauth

Catalina:

2019-05-14T14:29:35Z, TRACE, http.PwmRequest, {210} GET request for: /sspr/private/setup-responses (no params) requestID=157 [172.18.87.134]
2019-05-14T14:29:35Z, TRACE, oauth.OAuthMachine, {210} preparing to redirect user to oauth authentication service, setting nextUrl to /sspr/private/setup-responses [172.18.87.134]
2019-05-14T14:29:35Z, TRACE, oauth.OAuthMachine, {210} issuing oauth state id=10 with the next destination URL set to /sspr/private/setup-responses [172.18.87.134]
2019-05-14T14:29:35Z, TRACE, oauth.OAuthMachine, calculated oauth self end point URI as 'https://www.inet.jnet.beta.pa.gov/sspr/public/oauth' using method SiteURL Setting
2019-05-14T14:29:35Z, TRACE, state.CryptoCookieLoginImpl, {210} wrote LoginInfoBean={"a":false,"p":"*hidden*","t":"UNAUT HENTICATED","af":[],"rq":"2019-05-14T18:29:35Z","g":"jve4ovbtdyiDkhyBEhIas0t5XHPyiq1 2ScfTzglCUKhTAGYN1BaKxV0jHXHWMQHb
EHtAeZ3A","c":0,"lf":[]} [172.18.87.134]
2019-05-14T14:29:35Z, TRACE, http.PwmResponse, {210} sending 302 redirect to https://www.inet.jnet.beta.pa.gov:44...9j82VL6hjFpUGm
vupUOLb4LvpgLiOP_CEuvz8LBwzusF6IunMGTAcJ5vSkN9BI2u Ly7I03ttTouF6zpm97gKTWYoecL08q9i7V9ogFqAVf7TlanN5F gRMnzmJVp5Jdrn0QT5ysV5YcWoWBBzosSaGx1V4h2Hi_io998t V4lIW-pvpIKaUFAKRCeYmOivzTX9HS2PL0lWO9MMA2_i42KtpihYji3M sAAAAA%3D%3D&redirect_uri=https
%3A%2F%2Fwww.inet.jnet.beta.pa.gov%2Fsspr%2Fpublic %2Foauth [172.18.87.134]
2019-05-14T14:29:35Z, DEBUG, oauth.OAuthMachine, {210} redirecting user to oauth id server, url: https://www.inet.jnet.beta.pa.gov:44...UFdNLkdDTTEQ1a
7sebIB9j82VL6hjFpUGmvupUOLb4LvpgLiOP_CEuvz8LBwzusF 6IunMGTAcJ5vSkN9BI2uLy7I03ttTouF6zpm97gKTWYoecL08q 9i7V9ogFqAVf7TlanN5FgRMnzmJVp5Jdrn0QT5ysV5YcWoWBBz osSaGx1V4h2Hi_io998tV4lIW-pvpIKaUFAKRCeYmOivzTX9HS2PL0lWO9MMA2_i42KtpihYji3M sAAAAA%3D%3
D&redirect_uri=https%3A%2F%2Fwww.inet.jnet.beta.pa .gov%2Fsspr%2Fpublic%2Foauth [172.18.87.134]

Any advice, how to get this fixed?

Thanks
Nihith